CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-0535

The e1000 driver for Linux kernel 2.4.26 and earlier does not properly initialize memory before using it, which allows local users to read portions of kernel memory. NOTE: this issue was originally incorrectly reported as a "buffer overflow" by some sources.
Publish Date : 2004-08-06 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Overflow
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low 2004-05-14
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2004:413: kernel security update (Important) oval:com.redhat.rhsa:def:2004413 unix
RHSA-2004:413: kernel security update (Important) oval:com.redhat.rhsa:def:20040413 unix
The e1000 driver for Linux kernel 2.4.26 and earlier does not properly initialize memory before using it, which allows l... oval:org.mitre.oval:def:11136 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-0535

# Product Type Vendor Product Version Update Edition Language
1 OS Conectiva Linux 8.0 Version Details Vulnerabilities
2 OS Conectiva Linux 9.0 Version Details Vulnerabilities
3 OS Engardelinux Secure Community 2.0 Version Details Vulnerabilities
4 OS Engardelinux Secure Linux 1.5 Professional Version Details Vulnerabilities
5 OS Gentoo Linux 1.4 Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.4.0 Test5 Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.4.0 Test11 Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.4.0 Test6 Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.4.0 Test12 Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.4.0 Test7 Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.4.0 Test2 Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.4.0 Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.4.0 Test8 Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.4.0 Test3 Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.4.0 Test1 Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.4.0 Test9 Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.4.0 Test4 Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.4.0 Test10 Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.4.1 Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.4.2 Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.4.3 Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.4.4 Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.4.5 Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.4.6 Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.4.7 Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.4.8 Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.4.9 Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.4.10 Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.4.11 Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.4.12 Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.4.13 Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.4.14 Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.4.15 Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.4.16 Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.4.17 Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.4.18 Pre1 Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.4.18 Pre7 Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.4.18 Pre2 Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.4.18 Pre8 Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.4.18 Pre3 Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.4.18 Pre4 Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.4.18 Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.4.18 Pre5 Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.4.18 X86 Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.4.18 Pre6 Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.4.19 Pre3 Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.4.19 Pre4 Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.4.19 Pre5 Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.4.19 Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.4.19 Pre6 Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.4.19 Pre1 Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.4.19 Pre2 Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.4.20 Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.4.21 Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.4.21 Pre1 Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.4.21 Pre4 Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.4.21 Pre7 Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.4.22 Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.4.23 Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.4.23 Pre9 Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.4.23 Ow2 Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.4.24 Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.4.24 Ow1 Version Details Vulnerabilities
64 OS Linux Linux Kernel 2.4.25 Version Details Vulnerabilities
65 OS Linux Linux Kernel 2.4.26 Version Details Vulnerabilities
66 OS Linux Linux Kernel 2.4.27 Pre1 Version Details Vulnerabilities
67 OS Mandrakesoft Mandrake Linux 9.1 Version Details Vulnerabilities
68 OS Mandrakesoft Mandrake Linux 9.1 PPC Version Details Vulnerabilities
69 OS Mandrakesoft Mandrake Linux 9.2 Version Details Vulnerabilities
70 OS Mandrakesoft Mandrake Linux 9.2 Amd64 Version Details Vulnerabilities
71 OS Mandrakesoft Mandrake Linux 10.0 Amd64 Version Details Vulnerabilities
72 OS Mandrakesoft Mandrake Linux 10.0 Version Details Vulnerabilities
73 OS Mandrakesoft Mandrake Linux Corporate Server 2.1 Version Details Vulnerabilities
74 OS Mandrakesoft Mandrake Linux Corporate Server 2.1 X86 64 Version Details Vulnerabilities
75 Application Mandrakesoft Mandrake Multi Network Firewall 8.2 Version Details Vulnerabilities
76 Application Suse Suse Email Server 3.1 Version Details Vulnerabilities
77 Application Suse Suse Email Server III Version Details Vulnerabilities
78 OS Suse Suse Linux 7 Enterprise Server Version Details Vulnerabilities
79 OS Suse Suse Linux 8 Enterprise Server Version Details Vulnerabilities
80 OS Suse Suse Linux 8.0 Version Details Vulnerabilities
81 OS Suse Suse Linux 8.0 I386 Version Details Vulnerabilities
82 OS Suse Suse Linux 8.1 Version Details Vulnerabilities
83 OS Suse Suse Linux 8.2 Version Details Vulnerabilities
84 OS Suse Suse Linux 9.0 Version Details Vulnerabilities
85 OS Suse Suse Linux 9.0 X86 64 Version Details Vulnerabilities
86 OS Suse Suse Linux 9.1 Version Details Vulnerabilities
87 Application Suse Suse Linux Admin-cd For Firewall Version Details Vulnerabilities
88 Application Suse Suse Linux Connectivity Server Version Details Vulnerabilities
89 Application Suse Suse Linux Database Server Version Details Vulnerabilities
90 Application Suse Suse Linux Firewall Cd Version Details Vulnerabilities
91 Application Suse Suse Linux Firewall Live-cd Version Details Vulnerabilities
92 Application Suse Suse Linux Office Server Version Details Vulnerabilities
93 Application Suse Suse Office Server Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Conectiva Linux 2
Engardelinux Secure Community 1
Engardelinux Secure Linux 1
Gentoo Linux 1
Linux Linux Kernel 61
Mandrakesoft Mandrake Linux 6
Mandrakesoft Mandrake Linux Corporate Server 2
Mandrakesoft Mandrake Multi Network Firewall 1
Suse Suse Email Server 2
Suse Suse Linux 9
Suse Suse Linux Admin-cd For Firewall 1
Suse Suse Linux Connectivity Server 1
Suse Suse Linux Database Server 1
Suse Suse Linux Firewall Cd 1
Suse Suse Linux Firewall Live-cd 1
Suse Suse Linux Office Server 1
Suse Suse Office Server 1

- References For CVE-2004-0535

http://www.mandriva.com/security/advisories?name=MDKSA-2004:062
MANDRAKE MDKSA-2004:062
ftp://patches.sgi.com/support/free/security/advisories/20040804-01-U.asc
SGI 20040804-01-U
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125168 CONFIRM
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000845
CONECTIVA CLA-2004:845
http://security.gentoo.org/glsa/glsa-200407-02.xml
GENTOO GLSA-200407-02
http://lwn.net/Articles/91155/
FEDORA FEDORA-2004-186
http://www.redhat.com/support/errata/RHSA-2004-418.html
REDHAT RHSA-2004:418
http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-2.4.27.log CONFIRM
http://www.novell.com/linux/security/advisories/2004_20_kernel.html
SUSE SUSE-SA:2004:020
http://www.redhat.com/support/errata/RHSA-2004-413.html
REDHAT RHSA-2004:413
http://xforce.iss.net/xforce/xfdb/16159
XF linux-e1000-bo(16159)
http://www.securityfocus.com/bid/10352
BID 10352 Linux Kernel e1000 Ethernet Card Driver Kernel Memory Disclosure Vulnerability Release Date:2010-08-05

- Metasploit Modules Related To CVE-2004-0535

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.