CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-4345 (1 public exploit)

Exim 4.72 and earlier allows local users to gain privileges by leveraging the ability of the exim user account to specify an alternate configuration file with a directive that contains arbitrary commands, as demonstrated by the spool_directory directive.
Publish Date : 2010-12-14 Last Update Date : 2011-02-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.9
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Gain privileges
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
6.8
AV:L/AC:L/Au:S/C:C/I:C/A:C 2010-12-09 2010-12-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2010-4345 oval:org.opensuse.security:def:20104345 unix
DSA-2131-1 exim4 -- arbitrary code execution oval:org.mitre.oval:def:12720 unix
DSA-2154-1 exim4 -- privilege escalation oval:org.mitre.oval:def:12931 unix
DSA-2154-2 exim4 -- privilege escalation / regression oval:org.mitre.oval:def:12692 unix
ELSA-2011:0153: exim security update (Moderate) oval:org.mitre.oval:def:22839 unix
RHSA-2011:0153: exim security update (Moderate) oval:org.mitre.oval:def:21735 unix
RHSA-2011:0153: exim security update (Moderate) oval:com.redhat.rhsa:def:20110153 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-4345

# Product Type Vendor Product Version Update Edition Language
1 Application Exim Exim 2.10 Version Details Vulnerabilities
2 Application Exim Exim 2.11 Version Details Vulnerabilities
3 Application Exim Exim 2.12 Version Details Vulnerabilities
4 Application Exim Exim 3.00 Version Details Vulnerabilities
5 Application Exim Exim 3.01 Version Details Vulnerabilities
6 Application Exim Exim 3.02 Version Details Vulnerabilities
7 Application Exim Exim 3.03 Version Details Vulnerabilities
8 Application Exim Exim 3.10 Version Details Vulnerabilities
9 Application Exim Exim 3.11 Version Details Vulnerabilities
10 Application Exim Exim 3.12 Version Details Vulnerabilities
11 Application Exim Exim 3.13 Version Details Vulnerabilities
12 Application Exim Exim 3.14 Version Details Vulnerabilities
13 Application Exim Exim 3.15 Version Details Vulnerabilities
14 Application Exim Exim 3.16 Version Details Vulnerabilities
15 Application Exim Exim 3.20 Version Details Vulnerabilities
16 Application Exim Exim 3.21 Version Details Vulnerabilities
17 Application Exim Exim 3.22 Version Details Vulnerabilities
18 Application Exim Exim 3.30 Version Details Vulnerabilities
19 Application Exim Exim 3.31 Version Details Vulnerabilities
20 Application Exim Exim 3.32 Version Details Vulnerabilities
21 Application Exim Exim 3.33 Version Details Vulnerabilities
22 Application Exim Exim 3.34 Version Details Vulnerabilities
23 Application Exim Exim 3.35 Version Details Vulnerabilities
24 Application Exim Exim 3.36 Version Details Vulnerabilities
25 Application Exim Exim 4.00 Version Details Vulnerabilities
26 Application Exim Exim 4.01 Version Details Vulnerabilities
27 Application Exim Exim 4.02 Version Details Vulnerabilities
28 Application Exim Exim 4.03 Version Details Vulnerabilities
29 Application Exim Exim 4.04 Version Details Vulnerabilities
30 Application Exim Exim 4.05 Version Details Vulnerabilities
31 Application Exim Exim 4.10 Version Details Vulnerabilities
32 Application Exim Exim 4.11 Version Details Vulnerabilities
33 Application Exim Exim 4.12 Version Details Vulnerabilities
34 Application Exim Exim 4.14 Version Details Vulnerabilities
35 Application Exim Exim 4.20 Version Details Vulnerabilities
36 Application Exim Exim 4.21 Version Details Vulnerabilities
37 Application Exim Exim 4.22 Version Details Vulnerabilities
38 Application Exim Exim 4.23 Version Details Vulnerabilities
39 Application Exim Exim 4.24 Version Details Vulnerabilities
40 Application Exim Exim 4.30 Version Details Vulnerabilities
41 Application Exim Exim 4.31 Version Details Vulnerabilities
42 Application Exim Exim 4.32 Version Details Vulnerabilities
43 Application Exim Exim 4.33 Version Details Vulnerabilities
44 Application Exim Exim 4.34 Version Details Vulnerabilities
45 Application Exim Exim 4.40 Version Details Vulnerabilities
46 Application Exim Exim 4.41 Version Details Vulnerabilities
47 Application Exim Exim 4.42 Version Details Vulnerabilities
48 Application Exim Exim 4.43 Version Details Vulnerabilities
49 Application Exim Exim 4.44 Version Details Vulnerabilities
50 Application Exim Exim 4.50 Version Details Vulnerabilities
51 Application Exim Exim 4.51 Version Details Vulnerabilities
52 Application Exim Exim 4.52 Version Details Vulnerabilities
53 Application Exim Exim 4.53 Version Details Vulnerabilities
54 Application Exim Exim 4.54 Version Details Vulnerabilities
55 Application Exim Exim 4.60 Version Details Vulnerabilities
56 Application Exim Exim 4.61 Version Details Vulnerabilities
57 Application Exim Exim 4.62 Version Details Vulnerabilities
58 Application Exim Exim 4.63 Version Details Vulnerabilities
59 Application Exim Exim 4.64 Version Details Vulnerabilities
60 Application Exim Exim 4.65 Version Details Vulnerabilities
61 Application Exim Exim 4.66 Version Details Vulnerabilities
62 Application Exim Exim 4.67 Version Details Vulnerabilities
63 Application Exim Exim 4.68 Version Details Vulnerabilities
64 Application Exim Exim 4.69 Version Details Vulnerabilities
65 Application Exim Exim 4.70 Version Details Vulnerabilities
66 Application Exim Exim 4.71 Version Details Vulnerabilities
67 Application Exim Exim 4.72 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Exim Exim 67

- References For CVE-2010-4345

http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00003.html
SUSE SUSE-SA:2010:059
http://lists.exim.org/lurker/message/20101210.164935.385e04d0.en.html
MLIST [exim-dev] 20101210 Re: Remote root vulnerability in Exim
http://bugs.exim.org/show_bug.cgi?id=1044 CONFIRM
http://www.vupen.com/english/advisories/2011/0135
VUPEN ADV-2011-0135
http://secunia.com/advisories/42576
SECUNIA 42576
http://openwall.com/lists/oss-security/2010/12/10/1
MLIST [oss-security] 20101210 Exim remote root
http://secunia.com/advisories/42930
SECUNIA 42930
http://secunia.com/advisories/43128
SECUNIA 43128
http://secunia.com/advisories/43243
SECUNIA 43243
http://www.cpanel.net/2010/12/critical-exim-security-update.html CONFIRM
http://www.debian.org/security/2010/dsa-2131
DEBIAN DSA-2131
http://www.debian.org/security/2011/dsa-2154
DEBIAN DSA-2154
Exploit! http://www.metasploit.com/modules/exploit/unix/smtp/exim4_string_format
http://www.exim.org/lurker/message/20101207.215955.bb32d4f2.en.html
MLIST [exim-dev] 20101207 Remote root vulnerability in Exim
http://www.redhat.com/support/errata/RHSA-2011-0153.html
REDHAT RHSA-2011:0153
http://www.vupen.com/english/advisories/2010/3171
VUPEN ADV-2010-3171
http://www.ubuntu.com/usn/USN-1060-1
UBUNTU USN-1060-1
http://www.securityfocus.com/archive/1/archive/1/515172/100/0/threaded
BUGTRAQ 20101213 Exim security issue in historical release
http://www.securitytracker.com/id?1024859
SECTRACK 1024859
http://www.securityfocus.com/bid/45341
BID 45341 Exim ALT_CONFIG_ROOT_ONLY 'exim' User Local Privilege Escalation Vulnerability Release Date:2011-02-10
http://www.vupen.com/english/advisories/2010/3204
VUPEN ADV-2010-3204
http://www.theregister.co.uk/2010/12/11/exim_code_execution_peril/
http://www.vupen.com/english/advisories/2011/0245
VUPEN ADV-2011-0245
http://www.vupen.com/english/advisories/2011/0364
VUPEN ADV-2011-0364
http://www.kb.cert.org/vuls/id/758489
CERT-VN VU#758489
https://bugzilla.redhat.com/show_bug.cgi?id=662012 CONFIRM
http://lists.exim.org/lurker/message/20101209.172233.abcba158.en.html
MLIST [exim-dev] 20101209 Re: [Exim-maintainers] Remote root vulnerability in Exim

- Metasploit Modules Related To CVE-2010-4345

Exim4 string_format Function Heap Buffer Overflow
This module exploits a heap buffer overflow within versions of Exim prior to version 4.69. By sending a specially crafted message, an attacker can corrupt the heap and execute arbitrary code with the privileges of the Exim daemon. The root cause is that no check is made to ensure that the buffer is not full prior to handling '%s' format specifiers within the 'string_vformat' function. In order to trigger this issue, we get our message rejected by sending a message that is too large. This will call into log_write to log rejection headers (which is a default configuration setting). After filling the buffer, a long header string is sent. In a successful attempt, it overwrites the ACL for the 'MAIL FROM' command. By sending a second message, the string we sent will be evaluated with 'expand_string' and arbitrary shell commands can be executed. It is likely that this issue could also be exploited using other techniques such as targeting in-band heap management structures, or perhaps even function pointers stored in the heap. However, these techniques would likely be far more platform specific, more complicated, and less reliable. This bug was original found and reported in December 2008, but was not properly handled as a security issue. Therefore, there was a 2 year lag time between when the issue was fixed and when it was discovered being exploited in the wild. At that point, the issue was assigned a CVE and began being addressed by downstream vendors. An additional vulnerability, CVE-2010-4345, was also used in the attack that led to the discovery of danger of this bug. This bug allows a local user to gain root privileges from the Exim user account. If the Perl interpreter is found on the remote system, this module will automatically exploit the secondary bug as well to get root.
Module type : exploit Rank : excellent Platforms : Unix


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.