CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-0235

Heap-based buffer overflow in the __nss_hostname_digits_dots function in glibc 2.2, and other 2.x versions before 2.18, allows context-dependent attackers to execute arbitrary code via vectors related to the (1) gethostbyname or (2) gethostbyname2 function, aka "GHOST."
Publish Date : 2015-01-28 Last Update Date : 2017-11-09
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Related OVAL Definitions

Title Definition Id Class Family
DSA-3142-1 -- eglibc -- security update oval:org.mitre.oval:def:28528 unix
ELSA-2015-0090 -- glibc security update (critical) oval:org.mitre.oval:def:28638 unix
ELSA-2015-0092 -- glibc security update (critical) oval:org.mitre.oval:def:28622 unix
RHSA-2015:0090 -- glibc security update (Critical) oval:org.mitre.oval:def:28360 unix
RHSA-2015:0090: glibc security update (Critical) oval:com.redhat.rhsa:def:20150090 unix
RHSA-2015:0092 -- glibc security update (Critical) oval:org.mitre.oval:def:28438 unix
RHSA-2015:0092: glibc security update (Critical) oval:com.redhat.rhsa:def:20150092 unix
USN-2485-1 -- GNU C Library vulnerability oval:org.mitre.oval:def:28503 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2015-0235

# Product Type Vendor Product Version Update Edition Language
1 Application GNU Glibc 2.0 Version Details Vulnerabilities
2 Application GNU Glibc 2.0.1 Version Details Vulnerabilities
3 Application GNU Glibc 2.0.2 Version Details Vulnerabilities
4 Application GNU Glibc 2.0.3 Version Details Vulnerabilities
5 Application GNU Glibc 2.0.4 Version Details Vulnerabilities
6 Application GNU Glibc 2.0.5 Version Details Vulnerabilities
7 Application GNU Glibc 2.0.6 Version Details Vulnerabilities
8 Application GNU Glibc 2.1 Version Details Vulnerabilities
9 Application GNU Glibc 2.1.1 Version Details Vulnerabilities
10 Application GNU Glibc 2.1.1.6 Version Details Vulnerabilities
11 Application GNU Glibc 2.1.2 Version Details Vulnerabilities
12 Application GNU Glibc 2.1.3 Version Details Vulnerabilities
13 Application GNU Glibc 2.1.9 Version Details Vulnerabilities
14 Application GNU Glibc 2.2 Version Details Vulnerabilities
15 Application GNU Glibc 2.2.1 Version Details Vulnerabilities
16 Application GNU Glibc 2.2.2 Version Details Vulnerabilities
17 Application GNU Glibc 2.2.3 Version Details Vulnerabilities
18 Application GNU Glibc 2.2.4 Version Details Vulnerabilities
19 Application GNU Glibc 2.2.5 Version Details Vulnerabilities
20 Application GNU Glibc 2.10.1 Version Details Vulnerabilities
21 Application GNU Glibc 2.11 Version Details Vulnerabilities
22 Application GNU Glibc 2.11.1 Version Details Vulnerabilities
23 Application GNU Glibc 2.11.2 Version Details Vulnerabilities
24 Application GNU Glibc 2.11.3 Version Details Vulnerabilities
25 Application GNU Glibc 2.12 Version Details Vulnerabilities
26 Application GNU Glibc 2.12.1 Version Details Vulnerabilities
27 Application GNU Glibc 2.12.2 Version Details Vulnerabilities
28 Application GNU Glibc 2.13 Version Details Vulnerabilities
29 Application GNU Glibc 2.14 Version Details Vulnerabilities
30 Application GNU Glibc 2.14.1 Version Details Vulnerabilities
31 Application GNU Glibc 2.15 Version Details Vulnerabilities
32 Application GNU Glibc 2.16 Version Details Vulnerabilities
33 Application GNU Glibc 2.17 Version Details Vulnerabilities
34 Application Oracle Communications Applications 13.1 Version Details Vulnerabilities
35 Application Oracle Oracle Pillar Axiom 6.1 Version Details Vulnerabilities
36 Application Oracle Oracle Pillar Axiom 6.2 Version Details Vulnerabilities
37 Application Oracle Oracle Pillar Axiom 6.3 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
GNU Glibc 33
Oracle Communications Applications 1
Oracle Oracle Pillar Axiom 3

- References For CVE-2015-0235

http://www-01.ibm.com/support/docview.wss?uid=swg21696600 CONFIRM
https://kb.juniper.net/InfoCenter/index?page=content&id=JSA10671 CONFIRM
http://secunia.com/advisories/62758
SECUNIA 62758
http://secunia.com/advisories/62812
SECUNIA 62812
http://secunia.com/advisories/62813
SECUNIA 62813
http://secunia.com/advisories/62816
SECUNIA 62816
http://secunia.com/advisories/62865
SECUNIA 62865
http://secunia.com/advisories/62870
SECUNIA 62870
http://secunia.com/advisories/62871
SECUNIA 62871
http://secunia.com/advisories/62879
SECUNIA 62879
http://secunia.com/advisories/62883
SECUNIA 62883
http://support.apple.com/kb/HT204942 CONFIRM
http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html CONFIRM
https://www.f-secure.com/en/web/labs_global/fsc-2015-1 CONFIRM
https://support.apple.com/HT205267 CONFIRM
https://security.gentoo.org/glsa/201503-04
GENTOO GLSA-201503-04
https://security.netapp.com/advisory/ntap-20150127-0001/ CONFIRM
https://bto.bluecoat.com/security-advisory/sa90 CONFIRM
https://community.qualys.com/blogs/laws-of-vulnerabilities/2015/01/27/the-ghost-vulnerability
https://kc.mcafee.com/corporate/index?page=content&id=SB10100 CONFIRM
https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04874668 CONFIRM
http://packetstormsecurity.com/files/130768/EMC-Secure-Remote-Services-GHOST-SQL-Injection-Command-Injection.html
http://www.securityfocus.com/bid/91787
BID 91787 Oracle July 2016 Critical Patch Update Multiple Vulnerabilities Release Date:2016-10-10
http://www.securitytracker.com/id/1032909
SECTRACK 1032909
http://www.websense.com/support/article/kbarticle/Vulnerabilities-resolved-in-TRITON-APX-Version-8-0 CONFIRM
http://www.securityfocus.com/archive/1/archive/1/534845/100/0/threaded
BUGTRAQ 20150311 OpenSSL v1.0.2 for Linux affected by CVE-2015-0235
http://www.securityfocus.com/bid/72325
BID 72325 GNU glibc CVE-2015-0235 Remote Heap Buffer Overflow Vulnerability Release Date:2017-10-18
http://lists.apple.com/archives/security-announce/2015/Jun/msg00002.html
APPLE APPLE-SA-2015-06-30-2
http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html CONFIRM
https://www.sophos.com/en-us/support/knowledgebase/121879.aspx CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21696526 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21695695 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21695774 CONFIRM
http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21696618 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21695835 CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2015:039
MANDRIVA MDVSA-2015:039
http://www.idirect.net/Partners/~/media/Files/CVE/iDirect-Posted-Common-Vulnerabilities-and-Exposures.pdf CONFIRM
http://seclists.org/oss-sec/2015/q1/269
BUGTRAQ 20150127 GHOST gethostbyname() heap overflow in glibc (CVE-2015-0235)
http://seclists.org/oss-sec/2015/q1/274
BUGTRAQ 20150127 Qualys Security Advisory CVE-2015-0235 - GHOST: glibc gethostbyname buffer overflow
http://www.debian.org/security/2015/dsa-3142
DEBIAN DSA-3142
https://support.apple.com/HT205375 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21696602 CONFIRM
http://rhn.redhat.com/errata/RHSA-2015-0126.html
REDHAT RHSA-2015:0126
http://seclists.org/fulldisclosure/2015/Jan/111
FULLDISC 20150128 Qualys Security Advisory CVE-2015-0235 - GHOST: glibc gethostbyname buffer overflow
https://www.qualys.com/research/security-advisories/GHOST-CVE-2015-0235.txt
http://packetstormsecurity.com/files/130974/Exim-GHOST-glibc-gethostbyname-Buffer-Overflow.html
http://www-01.ibm.com/support/docview.wss?uid=swg21696131 CONFIRM
http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21696243 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21695860 CONFIRM
http://linux.oracle.com/errata/ELSA-2015-0092.html CONFIRM
http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html
APPLE APPLE-SA-2015-09-30-3
http://marc.info/?l=bugtraq&m=142296726407499&w=2
HP HPSBGN03247
http://marc.info/?l=bugtraq&m=142721102728110&w=2
HP SSRT101953
http://marc.info/?l=bugtraq&m=142722450701342&w=2
HP HPSBGN03285
http://marc.info/?l=bugtraq&m=142781412222323&w=2
HP SSRT101937
http://marc.info/?l=bugtraq&m=143145428124857&w=2
HP HPSBMU03330
http://packetstormsecurity.com/files/130171/Exim-ESMTP-GHOST-Denial-Of-Service.html
http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html CONFIRM
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20150128-ghost
CISCO 20150128 GNU glibc gethostbyname Function Buffer Overflow Vulnerability
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html CONFIRM
http://lists.apple.com/archives/security-announce/2015/Oct/msg00005.html
APPLE APPLE-SA-2015-10-21-4
http://blogs.sophos.com/2015/01/29/sophos-products-and-the-ghost-vulnerability-affecting-linux/ CONFIRM
http://linux.oracle.com/errata/ELSA-2015-0090.html CONFIRM

- Metasploit Modules Related To CVE-2015-0235

Exim GHOST (glibc gethostbyname) Buffer Overflow
This module remotely exploits CVE-2015-0235, aka GHOST, a heap-based buffer overflow in the GNU C Library's gethostbyname functions on x86 and x86_64 GNU/Linux systems that run the Exim mail server.
Module type : exploit Rank : great Platforms : Unix
WordPress XMLRPC GHOST Vulnerability Scanner
This module can be used to determine hosts vulnerable to the GHOST vulnerability via a call to the WordPress XMLRPC interface. If the target is vulnerable, the system will segfault and return a server error. On patched systems, a normal XMLRPC error is returned.
Module type : auxiliary Rank : normal


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.